Just a dump of certain commands to remember to configure for starting up a VMX
Some Chassis/system base settings
Start by setting the license, you can get a demo for free from https://www.juniper.net/us/en/dm/free-vmx-trial/
Then we add the license using
request system license add terminal
once this is completed we are good to configure:
set system host-name [name]
set system syslog user * any emergency
set system syslog user * match “!(.*Scheduler Oinker*.|.*Frame 0*.|.*ms without yielding*.)”
set chassis fpc 0 lite-mode
set chassis network-services ip
set chassis aggregated-devices ethernet device-count 100
set protocols lldp interface all
delete chassi auto-image-upgrade
set system root-authentication plain-text-password
Password
commit and-quit
At this point the device is good but you really need to restart the FPC to get it into lite mode…
lets do that with a restart chassis-control
THE ABOVE COMMAND WILL TAKE AT LEAST 5 MINUETS TO REBOOT THE FPC!
Confirm status once rebooted with show chassis fpc
Configuring a lag
set interfaces ae0 aggregated-ether-options lacp active
-Without this the lacp service won’t run and won’t send packets
set interfaces ae0 unit 0 family inet address [address]
set interfaces ge-0/0/0 ether-options 802.3ad ae0